Monday, October 26, 2009

Use Foxit Reader On Linux


Foxit Reader is a free PDF document viewer for the Linux platform, with a new streamlined interface, user-customized toolbar, incredibly small size, breezing-fast launch speed and rich features. This empowers PDF document users with Zoom function, Navigation function, Bookmarks, Thumbnails, Text Selection Tool, Snapshot, and Full Screen capabilities. Foxit Reader for Desktop Linux is provided by Foxit Corporation free for non-commercial use.


Advantages

Before Foxit's Reader for Desktop Linux was available, users would have to download PDF Reader software that is much bigger in size and much slower and then wait for its lengthy installation process to be completed.

Now with Foxit Reader for Desktop Linux, you will not experience these previous troubles any more. Foxit reader for Desktop Linux is completely free. And the following is a list of compelling advantages of Foxit Reader for Desktop Linux.

  • Incredibly small: The download size of Foxit Reader for Linux is extremely small.
  • Minimal memory consumption: The memory consumption is less than 15MB.
  • Amazing fast: When you run Foxit Reader, it launches instantly without any delay and loads a PDF file less than 3 seconds .
  • High security and privacy: Foxit Reader highly respects the security and privacy of users and will never connect to the Internet without the user's permission
Known Issues
Foxit Reader 1.1 for Desktop Linux

1. Can’t record the Navigation Panel status when a user exits.
2. Can’t keep refreshing the list of recent files in real time.
3. The page scrolling feature is invalid if finding text is not finished.




Install Foxit Reader in Ubuntu
Use the following command
wget http://mirrors.foxitsoftware.com/pub/foxit/reader/desktop/linux/1.x/1.1/enu/FoxitReader_1.1.0_i386.deb
Now you have .deb package install this package using the following command
sudo dpkg -i FoxitReader_1.1.0_i386.deb
Now you can open Foxit Reader via Applications > Office > FoxitReader




5 comments:

  1. I receive following error
    root@ubuntu:~# dpkg -i FoxitReader_1.1.0_i386.deb
    dpkg: error processing FoxitReader_1.1.0_i386.deb (--install):
    package architecture (i386) does not match system (amd64)
    Errors were encountered while processing:
    FoxitReader_1.1.0_i386.deb

    ReplyDelete
  2. I get the same error. And like all linux sites, there is no followup by the author to a year old post. Its an impossible system, meant for geeks, but with contempt for human beings.

    ReplyDelete
  3. Yea, visible after approval. From Linux people? I don't think so.

    ReplyDelete
  4. Foxit error:
    You guys are using the 64 bit version of Ubuntu, but the software is only compatible with 32 bit Linux.

    ReplyDelete
  5. Hy Guys :

    sudo dpkg -i --force-architecture FoxitReader_1.1.0_i386.deb
    should work

    Zsolt Okner

    ReplyDelete

Note: Only a member of this blog may post a comment.

Related Content

Related Posts with Thumbnails